Installation

For apache cassandra version 3.x

npm install express-cassandra

For datastax enterprise version 5.x

npm install express-cassandra dse-driver@1.2.0

For older cassandra 2.x

npm install express-cassandra@0.5.4

Please note that if you use the legacy cassandra 2.x compliant version then please use the corresponding README.md file for that version. The following documentation is for version 3.x and datastax enterprise 5.x only. The materialized view support and several other part of the documentation is strictly applicable for cassandra 3.x / dse 5.x and will not work in earlier versions of cassandra.